Multiple issues with V12



After upgrade to v12 ( P20230412) we are seeing alot of issues that we did not see in v11. I have looked at the top issue tracker thread and also trying to search to see if there is other with same problem as we have. But to my surprise I can't find any useful information. But at the same time I don't think we are the only one with these issues. Below is some of the problems:

"All VMs have been prepared for storage snapshot"
- We have some jobs where we use storage snapshot. This step in v12 is taking a very longtime compared to v11. We are seeing this issue on a couple of jobs. But there is one job that is really bad. This step took ~3 - 5 min in v11. Now in v12 it takes ~6 h everyday. We can see that this problem started at the first run with v12.. Case: 06063316

"Error: Failed to check whether snapshot is in progress (network mode).RPC function call failed. Function name: [IsSnapshotInProgress]. Target machine:.RPC error:The RPC server is unavailable. Code: 1722
- We have started seeing many rpc errors during application aware processing. Also this is something that has started with the first run i v12. These are jobs that has worked fine with v11. But after upgrade not working anymore.. Case: 06066873

Veeam remote console crash / hangs
- 30 - 40% the remote console crash when we edit jobs. I happens only during edit of jobs. Never seen this before. Started with version 12. First we thought this happened beacuse of antivirus software. But we have the same issues also on servers without antivirus.

Error: Exception of type 'Veeam.Backup.AgentProvider.AgentClosedException' was thrown.
- VM backup fails with above error. Never seen this issue before v12.

Error: VSSControl: Failed to freeze guest over Hypervisor API, wait timeout
- VM backup fails with above error. These are vm backup that has worked fine in v11 but started getting this error in v12.

Troubleshooting steps we have taken is to restart all Windows Veeam servers in our environments and for some of the issues a support case is opened. Problem with the support cases is that they are threated like individual cases and troubleshooted like it is not a v12 issue. Even though the problem started with the first run in v12. Any one else seeing the same problems? We backup many vms and most of the still work fine in v12. But we are seeing alot more errors in v12 than with v11.