Installing Apache

Discussion in 'Web Hosting and Domain Names' started by AusQB, Mar 10, 2009.

to remove all ads.
  1. AusQB

    AusQB New Member

    Messages:
    167
    I'm completely lost. Can someone give me a very basic guide to installing Apache 2.0.x on Windows XP?

    I've installed the thing, but can't get that "It works!" page to come up. I'm not sure where the problem is, and I don't have an error log for some reason.

    EDIT: I get this error when trying to start the Apache server:

    Link


    Also, if I run a web server from my computer, do I still need to purchase a domain name?
     
    Last edited: Mar 10, 2009
  2. jnjc

    jnjc New Member

    Messages:
    493
    At a guess it looks like IIS is running on that machine. There is a version of IIS on XP which allows local connections. Apache is saying it can't listen on port 80 because something else is. Port 80 is your http port so it's most likely IIS thats already listening on the port. Stop IIS and then try and run Apache.

    HTH,
    JC
     
  3. AusQB

    AusQB New Member

    Messages:
    167
    It can't be IIS. After Apache didn't work, I installed IIS to see if that works.
     
  4. jnjc

    jnjc New Member

    Messages:
    493
    Where you getting the same message before you installed IIS ?
    I'd remove IIS before you go any further and then try again.
    Have you tried googling the error message ?
     
  5. cmjvulavala

    cmjvulavala New Member

    Messages:
    49
    You could completely uninstall Apache and then run a program such as WAMP or The Saint Wamp as these will install Apache configured with PHP and mySQL in one packages. You dont learn how to setup the server but judging by how you havent searched Google for the error yet I'm guessing you are a novice with setting up/running a webserver
     
  6. AusQB

    AusQB New Member

    Messages:
    167
    I didn't Google the specific error, but I browsed through a lot of FAQs and Wiki's for any hint at what should be a very obvious and simple mistake on my part.

    But don't worry anymore, I decided to let it go.

    I really only wanted it for testing purposes, which by the way, can I install PHP by itself in order to preview php files locally?
     
  7. conor

    conor New Member

    Messages:
    348
    You don't need PHP installed to do that.
     
  8. AusQB

    AusQB New Member

    Messages:
    167
    Then what? I need something to parse the php functions on my machine.
     
  9. cmjvulavala

    cmjvulavala New Member

    Messages:
    49
    The best way to test PHP files is on a webserver... you can run PHP not on a webserver but its weird. Your best bet is the pre-configured servers I posted URIs to earlier.
     
  10. jnjc

    jnjc New Member

    Messages:
    493
    I run PHP on my XP laptop and it works just fine. Go to the php.net and download the windows installer, it pretty much takes care of everything...

    HTH,
    JC
     
  11. conor

    conor New Member

    Messages:
    348
    Sorry I mis-read your question. Yes you do need PHP. Try WAMP (Windows,Apache,MySQL,PHP)

    You can download it here:

    http://www.wampserver.com/en/download.php
     
  12. AusQB

    AusQB New Member

    Messages:
    167
    Thanks, and sorry if I sounded uptight.
     
  13. Lonny Earl

    Lonny Earl Banned

    Messages:
    41
    Hi,

    Go to the following site:.wampserver.com
    Download WAMP5 .It'll install Apache,PHP5,My SQL. u no need to configure. It'll automatically configure.
     
  14. designsatlanta

    designsatlanta Banned

    Messages:
    14
    There is a version of IIS on XP which allows local connections. Apache is saying it can't listen on port 80 because something else is. Port 80 is your http port so it's most likely IIS thats already listening on the port.
     
  15. designsatlanta

    designsatlanta Banned

    Messages:
    14
    At a guess it looks like IIS is running on that machine. There is a version of IIS on XP which allows local connections. Apache is saying it can't listen on port 80 because something else is. Port 80 is your http port so it's most likely IIS thats already listening on the port. Stop IIS and then try and run Apache.
     

Share This Page